jump to navigation

installing oc8i extension in debian April 13, 2012

Posted by maxmil in : Uncategorized , trackback

At the time of writing there are only the instantclient-basic and instantclient-sqlplus packages available in the debian repos.

Building the extension from source (using pecl) requires the instantclient-sdk package.

Since i could not find this for debian i used the rpm’s on oracles download site.

First convert them to deb’s using alien.

Then dpkg -i

Then pecl install oci8

Finally add the extension to the php.ini used by apache and reload apache.

Comments»

no comments yet - be the first?