jump to navigation

Alfresco: A previous schema upgrade failed. Revert to the original database before attempting the upgrade again. January 23, 2008

Posted by maxmil in : Alfresco , 7 comments

Alfresco 2.1 sometimes refuses to start with the error

Caused by: org.alfresco.error.AlfrescoRuntimeException: A previous schema upgrade failed. Revert to the original database before attempting the upgrade again.

Not quite sure how this comes about, think that it can be from a failed start previously, but a solution is to drop the table alf_bootstrap_lock and try again.